// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/\*[\s\S]*?\*\/|([^\\:]|^)\/\/.*$").unwrap();
let string = "// comments at the beginning of the file are removed
********************************************************
Please take note of the items highlighted in green//.
These are held in back reference \"$1\" which you MUST
use in your replacement value or else your program will
break.//
********************************************************
/*
Block comments are removed - easy peasy
*/
https://urls.are.preserved.for.you// and comments after them are removed
asdfasdf// the comment can bump right up to text
asdfasdf;// ...or a semicolon.
{
foo:// you will need a parser to remove this comment b/c it smells like a URL
\"bar\",// ...but not this one
boo: // ...or this one
\"who\"
}
x.replace(/\\//g, '/');
}//";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}