# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\/\*[\s\S]*?\*\/|([^\\:]|^)\/\/.*$"
test_str = ("// comments at the beginning of the file are removed\n\n"
"********************************************************\n"
"Please take note of the items highlighted in green//.\n"
"These are held in back reference \"$1\" which you MUST\n"
"use in your replacement value or else your program will\n"
"break.//\n"
"********************************************************\n\n"
"/*\n"
"Block comments are removed - easy peasy\n"
"*/\n\n"
"https://urls.are.preserved.for.you// and comments after them are removed\n"
"asdfasdf// the comment can bump right up to text\n"
"asdfasdf;// ...or a semicolon.\n\n"
"{\n"
" foo:// you will need a parser to remove this comment b/c it smells like a URL\n"
" \"bar\",// ...but not this one\n"
" boo: // ...or this one\n"
" \"who\"\n"
"}\n\n"
"x.replace(/\\//g, '/');\n\n"
"}//")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.