const regex = /[^_]+(?=\.html)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^_]+(?=\\.html)', 'gm')
const str = `20210608_081442_20-0000428456.html
20210608_081442_328456.html
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}