$re = '/[^_]+(?=\.html)/m';
$str = '20210608_081442_20-0000428456.html
20210608_081442_328456.html
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);