re = /[^_]+(?=\.html)/m
str = '20210608_081442_20-0000428456.html
20210608_081442_328456.html
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end