#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^_]+(?=\.html)"
Local $sString = "'"IIIIIIIIIIIIiIIIIIITIIiIIIIIfiI° W‘i’" & @CRLF & _
"INVOICE TO KN SALES INVOICE" & @CRLF & _
"BROSE SPARTANBURG , INC." & @CRLF & _
"1171 HOWELL ROAD KN TRACKING NUMBER 1036 303 978" & @CRLF & _
"STE.300 KN ACCOUNTING NO. 1036303978—2160" & @CRLF & _
"DUNCAN SC 29334 ACCOUNT NUMBER 8416043" & @CRLF & _
"UNITED STATES INVOICE NO. / DATE GSPN790430 02/01/2021" & @CRLF & _
"DUE DATE 03/03/2021" & @CRLF & _
"CONSIGNEE SHIPPER" & @CRLF & _
"BROSE SPARTANBURG , INC. KUEHNE + NAGEL (AG & CO.) KG" & @CRLF & _
"1171 HOWELL ROAD FS" & @CRLF & _
"STE.300 WILHELM-KAISEN-BRUECKE 1" & @CRLF & _
"DUNCAN SC 29334 28195 BREMEN" & @CRLF & _
"UNITED STATES GERMANY" & @CRLF & _
"__" & @CRLF & _
"VESSEL NAME : AL BAHIA VOYAGE NUMBER : 012W" & @CRLF & _
"PL. OF RECEIPT : KRONACH MOVEMENT TYPE : CFS/CY" & @CRLF & _
"P. OF LOADING : HAMBURG ETD/ATD : 12/30/2020" & @CRLF & _
"P. OF DISCHARGE : CHARLESTON, SC ETA/ATA : 01/18/2021" & @CRLF & _
"PL. OF DELIVERY : DUNCAN DANGEROUS GOODS : NO" & @CRLF & _
"TERMS OF TRADE : CFR DUNCAN INSURAN. STATUS : NOT ARRANGED BY KN" & @CRLF & _
"MARKS & NOS QTY TYPE DESCRIPTION OF GOODS WGHT VOL" & @CRLF & _
"1 40' HC AS PER AHTWEHED 10749.00 56.100" & @CRLF & _
"CODE CHARGE NAME USD" & @CRLF & _
"156 PRECARRIAGE 880.60" & @CRLF & _
"300 EXPORT CUSTOMS CLEARANCE 41.65" & @CRLF & _
"340 VGM FEE 15.00" & @CRLF & _
"400 THC - ORIGIN 357.00" & @CRLF & _
"550 SEAFREIGHT 1,561.00" & @CRLF & _
"581 AMS/ACI SECURITY FEE 45.00" & @CRLF & _
"570 BUC - BUNKER CHARGE 347.68" & @CRLF & _
"600 THC - DESTINATION 80.00" & @CRLF & _
"406 CONTAINER STUFFING EXPORT 426.16" & @CRLF & _
"SUBTOTAL USD 3,754.09" & @CRLF & _
"INVOICE TOTAL USD 3,754.09" & @CRLF & _
"g PAYABLE" & @CRLF & _
"BE CTD NUMBER: HLCUEUR2011DRZW7" & @CRLF & _
"fig AMS NUMBER: BANQBRE4631801" & @CRLF & _
"«'2" & @CRLF & _
"fig THE SHIPMENT IS EMITTING 2020.00 KGM KGS OF CO2 FROM KRONACH TO DUNCAN, SC." & @CRLF & _
"Egg THE VALUE IS ESTIMATED BASED ON CLEAN CARGO AND EN 16258 METHODOLOGIES." & @CRLF & _
"0X0;" & @CRLF & _
"2.5011" & @CRLF & _
"'13:" & @CRLF & _
"933" & @CRLF & _
"§§§ IEEE'SERF'IEAPDEWCS DR SUITE #EIé-11((886é1)8g79é-112§216 RemmmEIIfionguiIIyoaBQIeéa'BT Kuehne + Na el Inc" & @CRLF & _
"§§§ GREENV'LLE: SC 29507 .. maggppgéflfiectfiggflss ABA-021000089 SWIFT: cmusaa DEBRA (gRREfi—" & @CRLF & _
"32%" & @CRLF & _
"£55 KMSTDWSUS 00034887002021-02-01T12:43250.596052008AUSNIULTT"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")