import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^_]+(?=\\.html)";
final String string = "'\"IIIIIIIIIIIIiIIIIIITIIiIIIIIfiI° W‘i’\n"
+ "INVOICE TO KN SALES INVOICE\n"
+ "BROSE SPARTANBURG , INC.\n"
+ "1171 HOWELL ROAD KN TRACKING NUMBER 1036 303 978\n"
+ "STE.300 KN ACCOUNTING NO. 1036303978—2160\n"
+ "DUNCAN SC 29334 ACCOUNT NUMBER 8416043\n"
+ "UNITED STATES INVOICE NO. / DATE GSPN790430 02/01/2021\n"
+ "DUE DATE 03/03/2021\n"
+ "CONSIGNEE SHIPPER\n"
+ "BROSE SPARTANBURG , INC. KUEHNE + NAGEL (AG & CO.) KG\n"
+ "1171 HOWELL ROAD FS\n"
+ "STE.300 WILHELM-KAISEN-BRUECKE 1\n"
+ "DUNCAN SC 29334 28195 BREMEN\n"
+ "UNITED STATES GERMANY\n"
+ "__\n"
+ "VESSEL NAME : AL BAHIA VOYAGE NUMBER : 012W\n"
+ "PL. OF RECEIPT : KRONACH MOVEMENT TYPE : CFS/CY\n"
+ "P. OF LOADING : HAMBURG ETD/ATD : 12/30/2020\n"
+ "P. OF DISCHARGE : CHARLESTON, SC ETA/ATA : 01/18/2021\n"
+ "PL. OF DELIVERY : DUNCAN DANGEROUS GOODS : NO\n"
+ "TERMS OF TRADE : CFR DUNCAN INSURAN. STATUS : NOT ARRANGED BY KN\n"
+ "MARKS & NOS QTY TYPE DESCRIPTION OF GOODS WGHT VOL\n"
+ "1 40' HC AS PER AHTWEHED 10749.00 56.100\n"
+ "CODE CHARGE NAME USD\n"
+ "156 PRECARRIAGE 880.60\n"
+ "300 EXPORT CUSTOMS CLEARANCE 41.65\n"
+ "340 VGM FEE 15.00\n"
+ "400 THC - ORIGIN 357.00\n"
+ "550 SEAFREIGHT 1,561.00\n"
+ "581 AMS/ACI SECURITY FEE 45.00\n"
+ "570 BUC - BUNKER CHARGE 347.68\n"
+ "600 THC - DESTINATION 80.00\n"
+ "406 CONTAINER STUFFING EXPORT 426.16\n"
+ "SUBTOTAL USD 3,754.09\n"
+ "INVOICE TOTAL USD 3,754.09\n"
+ "g PAYABLE\n"
+ "BE CTD NUMBER: HLCUEUR2011DRZW7\n"
+ "fig AMS NUMBER: BANQBRE4631801\n"
+ "«'2\n"
+ "fig THE SHIPMENT IS EMITTING 2020.00 KGM KGS OF CO2 FROM KRONACH TO DUNCAN, SC.\n"
+ "Egg THE VALUE IS ESTIMATED BASED ON CLEAN CARGO AND EN 16258 METHODOLOGIES.\n"
+ "0X0;\n"
+ "2.5011\n"
+ "'13:\n"
+ "933\n"
+ "§§§ IEEE'SERF'IEAPDEWCS DR SUITE #EIé-11((886é1)8g79é-112§216 RemmmEIIfionguiIIyoaBQIeéa'BT Kuehne + Na el Inc\n"
+ "§§§ GREENV'LLE: SC 29507 .. maggppgéflfiectfiggflss ABA-021000089 SWIFT: cmusaa DEBRA (gRREfi—\n"
+ "32%\n"
+ "£55 KMSTDWSUS 00034887002021-02-01T12:43250.596052008AUSNIULTT";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}