using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*,\s*";
string input = @"item 1, item 3.0 ,item 8 , item 1.0 , item 4, item 5, item 6, item 10";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}