$re = '/\s*,\s*/';
$str = 'item 1, item 3.0 ,item 8 , item 1.0 , item 4, item 5, item 6, item 10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);