package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*,\s*`)
var str = `item 1, item 3.0 ,item 8 , item 1.0 , item 4, item 5, item 6, item 10`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}