re = /class(?=="(?:field|.*?\sfield|field\s.*?|.*?\sfield\s.*?)")/
str = 'Ex1: should match both of these:
<div class="something else field">Foo</div>
<div class="field something else">Foo</div>
<span class="field">Bar</span>
<span class="foo field bar">Bar</span>
Ex2: should not match
<div class="baseball-field baz">Baz</div>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end