import Foundation
let pattern = #"class(?=="(?:field|.*?\sfield|field\s.*?|.*?\sfield\s.*?)")"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Ex1: should match both of these:
<div class="something else field">Foo</div>
<div class="field something else">Foo</div>
<span class="field">Bar</span>
<span class="foo field bar">Bar</span>
Ex2: should not match
<div class="baseball-field baz">Baz</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)