package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[+]*[0-9\s]{1,4}[(]{0,1}[0-9]{1,4}[)]{0,1}[-\s\.\/0-9]*$`)
var str = `+33 (0) 751088120`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}