$re = '/^[+]*[0-9\s]{1,4}[(]{0,1}[0-9]{1,4}[)]{0,1}[-\s\.\/0-9]*$/m';
$str = '+33 (0) 751088120';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);