// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[+]*[0-9\s]{1,4}[(]{0,1}[0-9]{1,4}[)]{0,1}[-\s\.\/0-9]*$").unwrap();
let string = "+33 (0) 751088120";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}