const regex = /.*\/(.*?),/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\\/(.*?),', 'gm')
const str = `kloc/a6bb4232-f1c5-40fc-99d5-004046ff249d,10002,10430,false`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}