re = /.*\/(.*?),/m
str = 'kloc/a6bb4232-f1c5-40fc-99d5-004046ff249d,10002,10430,false'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end