const regex = new RegExp('/([^/.]+)$', 'gm')
const str = `www.mysite.com/page
www.mysite.com/doc1/doc2/page
www.mysite.com/page/
www.mysite.com/file.php
www.mysite.com/file.jpg
www.mysite.com/file.html
www.mysite.com/file.doc`;
const subst = `/\1/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);