using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(bo\pL+)\d+";
string input = @"newboay1fineboy8badboiy12 boy4andothersfollows...";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}