$re = '/(bo\pL+)\d+/';
$str = 'newboay1fineboy8badboiy12 boy4andothersfollows...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);