package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(bo\pL+)\d+`)
var str = `newboay1fineboy8badboiy12 boy4andothersfollows...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}