const regex = /\/product\/[A-z]{20,100}\/([0-9]{10,12})\./;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/product\\\/[A-z]{20,100}\\\/([0-9]{10,12})\\.', '')
const str = `ru.site.com/product/sdfgsdfgdsfgSDFGsdhsdFGSDGFs/65473276543.html?куча-get-параметров
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}