re = /\/product\/[A-z]{20,100}\/([0-9]{10,12})\./
str = 'ru.site.com/product/sdfgsdfgdsfgSDFGsdhsdFGSDGFs/65473276543.html?куча-get-параметров
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end