$re = '/\/product\/[A-z]{20,100}\/([0-9]{10,12})\./';
$str = 'ru.site.com/product/sdfgsdfgdsfgSDFGsdhsdFGSDGFs/65473276543.html?куча-get-параметров
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);