using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\s*)(,?)""([a-zA-Z0-9]+?)"":(\s*)""([a-zA-Z0-9]+?)""";
string input = @"{""key1"": ""value1"", ""key2"": ""value2""} ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}