re = /(\s*)(,?)"([a-zA-Z0-9]+?)":(\s*)"([a-zA-Z0-9]+?)"/m
str = '{"key1": "value1", "key2": "value2"} '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end