package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^\/]+)`)
var str = `ae-app001/UK/Server/company
ae-app001/UK/Server
string1/string2/string3/string4
string1/string2/string3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}