re = /^([^\/]+)/m
str = 'ae-app001/UK/Server/company
ae-app001/UK/Server
string1/string2/string3/string4
string1/string2/string3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end