$re = '/^([^\/]+)/m';
$str = 'ae-app001/UK/Server/company
ae-app001/UK/Server
string1/string2/string3/string4
string1/string2/string3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);