const regex = /^(?P<w>\d+)[.](?P<x>\d+)[.](?P<y>\d+)-(?P<z>android\d+)-(?P<k>\d+).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?P<w>\\d+)[.](?P<x>\\d+)[.](?P<y>\\d+)-(?P<z>android\\d+)-(?P<k>\\d+).*$', 'gm')
const str = `5.4.42-android12-0-00544-ged21d463f856`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}