#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)abc.+(?<=cddd|nn)(?<!bcddd)f"
Local $sString = "abcdddf" & @CRLF & _
"abcbbbf" & @CRLF & _
"abcmnnf" & @CRLF & _
"abcmmmf" & @CRLF & _
"abcnnnnnf" & @CRLF & _
"abc12nf" & @CRLF & _
"abcmmcdddf" & @CRLF & _
"abcvvvvvvvf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")