$re = '/abc.+(?<=cddd|nn)(?<!bcddd)f/m';
$str = 'abcdddf
abcbbbf
abcmnnf
abcmmmf
abcnnnnnf
abc12nf
abcmmcdddf
abcvvvvvvvf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);