re = /abc.+(?<=cddd|nn)(?<!bcddd)f/m
str = 'abcdddf
abcbbbf
abcmnnf
abcmmmf
abcnnnnnf
abc12nf
abcmmcdddf
abcvvvvvvvf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end