$re = '/^(?=.*\?)[a-zA-Z0-9\?]+$/m';
$str = 'ABC123?A
1ABCA?
?2ABCD
ABC123
ABC.?1D1
ABC(a)?1d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);