import re
regex = re.compile(r"^(?=.*\?)[a-zA-Z0-9\?]+$", flags=re.MULTILINE)
test_str = ("ABC123?A\n"
"1ABCA?\n"
"?2ABCD\n"
"ABC123\n"
"ABC.?1D1\n"
"ABC(a)?1d")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")