re = /^(?=.*\?)[a-zA-Z0-9\?]+$/m
str = 'ABC123?A
1ABCA?
?2ABCD
ABC123
ABC.?1D1
ABC(a)?1d'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end