$re = '/\A[&!*,#@\'"`{}[\]]/';
$str = 'Allows configuration of tasks to be executed in response to events.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);