import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(eq|[gln]e|[bclg]t)\\s*:\\s*\\d+(?:\\.\\d+)?(?:-\\d+(?:\\.\\d+)?)?$";
final String string = "eq:4\n"
+ "ne:41\n"
+ "gt:41-67\n"
+ "lt^:45\n"
+ "lt:43a\n"
+ "eq:**+4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}