re = /^(eq|[gln]e|[bclg]t)\s*:\s*\d+(?:\.\d+)?(?:-\d+(?:\.\d+)?)?$/m
str = 'eq:4
ne:41
gt:41-67
lt^:45
lt:43a
eq:**+4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end