import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+|\\b(?:[A-Z]+|\\w)";
final String string = "Freestyle steel\n"
+ "Freestyle Alloy\n"
+ "Trekking steel uk\n"
+ "Single speed\n"
+ "5 speed\n"
+ "15 speed\n"
+ "3 Speed internal gear with 55 coaster\n"
+ "MTB steel\n"
+ "Junior MTB";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}