import Foundation
let pattern = #"\d+|\b(?:[A-Z]+|\w)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Freestyle steel
Freestyle Alloy
Trekking steel uk
Single speed
5 speed
15 speed
3 Speed internal gear with 55 coaster
MTB steel
Junior MTB
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)