const regex = /\d+|\b(?:[A-Z]+|\w)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+|\\b(?:[A-Z]+|\\w)', 'g')
const str = `Freestyle steel
Freestyle Alloy
Trekking steel uk
Single speed
5 speed
15 speed
3 Speed internal gear with 55 coaster
MTB steel
Junior MTB`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}