package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\bEvent demon log entry:)(?:\r?\n|\r)+(\[[^]]+\].*)`)
var str = `Event demon log entry:
[27/12/2018 08:15:02] CAUAJM_I_40245 EVENT: ALARM ALARM: MAXRUNALARM JOB: p1_credit_qv_curve_snap MACHINE: p1prog06`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}