re = /(\bEvent demon log entry:)(?:\r?\n|\r)+(\[[^]]+\].*)/m
str = 'Event demon log entry:
[27/12/2018 08:15:02] CAUAJM_I_40245 EVENT: ALARM ALARM: MAXRUNALARM JOB: p1_credit_qv_curve_snap MACHINE: p1prog06'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end