$re = '/(\bEvent demon log entry:)(?:\r?\n|\r)+(\[[^]]+\].*)/m';
$str = 'Event demon log entry:
[27/12/2018 08:15:02] CAUAJM_I_40245 EVENT: ALARM ALARM: MAXRUNALARM JOB: p1_credit_qv_curve_snap MACHINE: p1prog06';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);