#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(house|car)(?: (?!(?:house|car)\b)\w+){1,10} (?!\1)(house|car)\b"
Local $sString = "car word1 word2 word3 word4 word5 word6 word7 word8 word9 word10 house" & @CRLF & _
"house word1 word2 word3 word4 word5 word6 word7 word8 word9 word10 car" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"house word1 word2 word3 word4 word5 word6 word7 word8 word9 word10 word 11 car" & @CRLF & _
"" & @CRLF & _
"car test car" & @CRLF & _
"house test house" & @CRLF & _
"house house house" & @CRLF & _
"car car car" & @CRLF & _
"this is a test house riding a new car" & @CRLF & _
"testing a car when testing a house test test test test test test test test test test test test house"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")