import re
regex = re.compile(r"\b(house|car)(?: (?!(?:house|car)\b)\w+){1,10} (?!\1)(house|car)\b", flags=re.MULTILINE)
test_str = ("car word1 word2 word3 word4 word5 word6 word7 word8 word9 word10 house\n"
"house word1 word2 word3 word4 word5 word6 word7 word8 word9 word10 car\n\n\n"
"house word1 word2 word3 word4 word5 word6 word7 word8 word9 word10 word 11 car\n\n"
"car test car\n"
"house test house\n"
"house house house\n"
"car car car\n"
"this is a test house riding a new car\n"
"testing a car when testing a house test test test test test test test test test test test test house")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")