#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(https?:\/\/)?([a-z0-9]+\.)*[a-z0-9]+\.[a-z]+$"
Local $sString = "http://www.sample.com" & @CRLF & _
"https://www.sample.com" & @CRLF & _
"https://www.sample.com#" & @CRLF & _
"http://www.sample.com/xyz" & @CRLF & _
"http://www.sample.com/#xyz" & @CRLF & _
"www.sample.com" & @CRLF & _
"www.sample.com/xyz/#/xyz" & @CRLF & _
"sample.com" & @CRLF & _
"sample.com?name=foo" & @CRLF & _
"http://www.sample.com#xyz" & @CRLF & _
"http://www.sample.c" & @CRLF & _
"sample.com" & @CRLF & _
"http://sample.com" & @CRLF & _
"https://sample.com" & @CRLF & _
"https://www.sample.com" & @CRLF & _
"https://sub.domain.com" & @CRLF & _
"https://sub.domain.com/" & @CRLF & _
"https://sub.domain.com/path" & @CRLF & _
"https://sub.domain.com/path/another" & @CRLF & _
"https://sub.domain.com?qs" & @CRLF & _
"https://sub.domain.com?q=search" & @CRLF & _
"https://sub.domain.com/test/?qs"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")