import Foundation
let pattern = #"^(https?:\/\/)?([a-z0-9]+\.)*[a-z0-9]+\.[a-z]+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
http://www.sample.com
https://www.sample.com
https://www.sample.com#
http://www.sample.com/xyz
http://www.sample.com/#xyz
www.sample.com
www.sample.com/xyz/#/xyz
sample.com
sample.com?name=foo
http://www.sample.com#xyz
http://www.sample.c
sample.com
http://sample.com
https://sample.com
https://www.sample.com
https://sub.domain.com
https://sub.domain.com/
https://sub.domain.com/path
https://sub.domain.com/path/another
https://sub.domain.com?qs
https://sub.domain.com?q=search
https://sub.domain.com/test/?qs
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)