package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(https?:\/\/)?([a-z0-9]+\.)*[a-z0-9]+\.[a-z]+$`)
var str = `http://www.sample.com
https://www.sample.com
https://www.sample.com#
http://www.sample.com/xyz
http://www.sample.com/#xyz
www.sample.com
www.sample.com/xyz/#/xyz
sample.com
sample.com?name=foo
http://www.sample.com#xyz
http://www.sample.c
sample.com
http://sample.com
https://sample.com
https://www.sample.com
https://sub.domain.com
https://sub.domain.com/
https://sub.domain.com/path
https://sub.domain.com/path/another
https://sub.domain.com?qs
https://sub.domain.com?q=search
https://sub.domain.com/test/?qs`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}